Webアーカイブ、単一のファイル(*.mht)を開けない?

フォーラム(掲示板)ルール
フォーラム(掲示板)ルールはこちら  ※コードを貼り付ける場合は [code][/code] で囲って下さい。詳しくはこちら
ゆりかもめ

Webアーカイブ、単一のファイル(*.mht)を開けない?

#1

投稿記事 by ゆりかもめ » 9年前

ごめんなさい!C言語問題ではありません。

homepageを「Webアーカイブ、単一のファイル(*.mht)」にして保存したら、
うまく開けないか、開いていも、空白のページになっています。
ページを保存する意味は全然ない、、、
どなたか、ご教授お願いします

beatle
記事: 1280
登録日時: 9年前
住所: 埼玉
連絡を取る:

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#2

投稿記事 by beatle » 9年前

ゆりかもめ さんが書きました:homepageを「Webアーカイブ、単一のファイル(*.mht)」にして保存したら、
とりあえずGoogle Chromeではその形式で保存できません。
使用しているブラウザとそのバージョンくらいは書いたほうが、回答をもらいやすいと思います。

アバター
h2so5
副管理人
記事: 2212
登録日時: 9年前
住所: 東京
連絡を取る:

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#3

投稿記事 by h2so5 » 9年前

mhtはIE専用の形式だったと思います。

ゆりかもめ

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#4

投稿記事 by ゆりかもめ » 9年前

皆さん早速ご返答ありがとうございます。

>使用しているブラウザとそのバージョンくらいは書いたほうが、回答をもらいやすいと思います。
Windows Internet Explorer8 2009です
32bitのWindowsで利用しています。
homepageを「Webページ、完全(*.htm;*.html)」で保存すれば、問題ないです。
ただ、ディフォルトとして、Webアーカイブ、単一のファイル(*.mht)であるため、
毎回、毎回「Webページ、完全(*.htm;*.html)」を選択するのは手数ですし、忘れる場合もあります。

「名前を付けてページ保存」が開いてページ保存する時、
「Webページ、完全(*.htm;*.html)」を保存のディフォルト形式にする方法はないでしょうか。

「Webアーカイブ、単一のファイル」がうまく利用できれば、どっちでもいいと思いますが。

また宜しくお願いします。

beatle
記事: 1280
登録日時: 9年前
住所: 埼玉
連絡を取る:

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#5

投稿記事 by beatle » 9年前

mhtにすると開けない、または白紙になるという現象は、どのwebページを保存した場合でも発生するのでしょうか。

少し調べたところ、mhtファイルのパス文字列の中に日本語が含まれると良くないようです。
半角英数字のパス(例えばC:\hoge.mht)へ保存して開いてみてください。

参考http://answers.microsoft.com/ja-jp/ie/f ... 9dcabb2f9c

ゆりかこめ

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#6

投稿記事 by ゆりかこめ » 9年前

さっそくご教授いただき本当にありがとうございます。
パス名に漢字やかなが存在することとは関係ないようです。
いろいろ試したところ、やっぱり保存するページによるようですね。
例えば、下記のページをmhtで保存して、開いた時にページメインの部分は全部空白になります。(右側のsub pageのみ表示されます。)
http://developer.nvidia.com/npp

因みに、元のページがオンライン表示する時に下記のメッセージが伴いましたページの上に出されています:
「このWebサイトは、'Adobe Systems Incorporated'からの'Adobe Flash Player'アドインを実行しようとしています。
Webサイトとアドインを信頼し、アドインの実効を許可するには、ここをクリックしてください」
これに関わりがあるでしょうか。

また宜しくお願いします。

beatle
記事: 1280
登録日時: 9年前
住所: 埼玉
連絡を取る:

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#7

投稿記事 by beatle » 9年前

ゆりかこめ さんが書きました:さっそくご教授いただき本当にありがとうございます。
パス名に漢字やかなが存在することとは関係ないようです。
いろいろ試したところ、やっぱり保存するページによるようですね。
例えば、下記のページをmhtで保存して、開いた時にページメインの部分は全部空白になります。(右側のsub pageのみ表示されます。)
http://developer.nvidia.com/npp
僕も試してみたところ、確かにメインページの部分が白くなりますね。
僕の場合、右側に加えて上側が表示されました。
保存したmhtを開く際に出るエラーを見たところ、
► スポイラーを表示
となっていました。

想像なのですが、mhtはHTMLや画像などを一つにまとめたファイルであり、
あるスクリプトがなにか書き込みをしようとして「書き込みできません」というエラーが出ているのでしょう。

とするとmhtでの保存は諦めるしか無いかもしれませんね。

アバター
あたっしゅ
記事: 334
登録日時: 10年前
住所: 東京23区
連絡を取る:

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#8

投稿記事 by あたっしゅ » 9年前

「ご教授(きょうじゅ)」は「ご教示(きょうじ)」では ?

http://developer.nvidia.com/npp を IE9 で、.mht で保存して、.mht を IE9 で見てみましたが、
メニューのところをのぞいて、ほぼ再現されました。

http://www.my-debugbar.com/wiki/IETester/HomePage
IETester で見てみたところ、IE5..IE8 mode は不調でした。

IE9 にできない Windows なんでしょうか ?


あたっしゅ
手提鞄あたっしゅ、[MrAtassyu] http://ameblo.jp/mratassyu/
手提鞄屋魚有店(てさげかばんやうおありてん)
レスがついていないものを優先して、レスしています。時々、見当外れなレスをします。

ゆりかもめ

Re: Webアーカイブ、単一のファイル(*.mht)を開けない?

#9

投稿記事 by ゆりかもめ » 9年前

皆さんいろいろご教示ありがとうございます。
一応解決しました。
空白になっているページに対して、
「最新の情報に更新」を実行するか、URLの処にフォーカスを当ててリターンすることによって、
うまく表示してくれる場合もありました。
原因ははっきり分かっていません。

閉鎖

“C言語何でも質問掲示板” へ戻る