不具合報告投稿所

トピックに返信する


答えを正確にご入力ください。答えられるかどうかでスパムボットか否かを判定します。

BBCode: ON
[img]: ON
[flash]: OFF
[url]: ON
スマイリー: OFF

トピックのレビュー
   

展開ビュー トピックのレビュー: 不具合報告投稿所

Re: 不具合報告投稿所

#49

by ニムロッド » 2ヶ月前

Hello again. I discovered something interesting. The SavedBarrageData problem doesn't happen on Windows 10. This is the first time I've seen Windows 10 actually fix something instead of breaking something...

Strangely, the corrupted folder is still created, even when I use Japanese locale. This also causes 設定.exe to not work properly, but editing Config.dat is easy.

I'm sure you're hard at work on 四聖龍神録2 Plus. I'm looking forward to it! I've thought about buying the 四聖龍神録2 premium package...

Re: 不具合報告投稿所

#48

by ニムロッド » 1年前

It's unusual. I don't have this problem with the first 四聖龍神録 at all, which also uses Japanese characters in file paths. Other programs I have that use Japanese characters in file paths don't have this problem either. If this is the cause for 四聖龍神録2, this is the first time I've seen it create a problem...

The v1.01 update stopped the gibberish folder from being created when I run the game, but it does get created if I run 設定.exe. I still get the SavedBarrageDat problem no matter what happens.

Re: 不具合報告投稿所

#47

by Dixq (管理人) » 1年前

To ニムロッド

I guess the problems with saving files are related to the character problems.
I didn't suppose that non-Japanese play this game.
I use Japanese character in file path. I should not use it.
I want to unify English character, but I must to convert the data of players that is already playing in Japan.
It's heavy...

> I might be able to help, but it's not a guarantee... please give me a few days?

Thank you. I'm glad to hear that.
Yes, I wait a few days.

Re: 不具合報告投稿所

#46

by ニムロッド » 1年前

Dixq, thank you for this update!

Are the problems with saving files related to the character problems? I hope not, but running it in every kind of Japanese locale does no good, and I don't have a Japanese version of Windows 7 to test...

A full translation would be a great outcome! I might be able to help, but it's not a guarantee... please give me a few days?

四聖龍神録

Re: 不具合報告投稿所

#45

by Dixq (管理人) » 1年前

Hi, ニムロッド.
Thank you for your reports.
V1.00 included the Bug that the Laser Dress sprite does not appear.
I fixed the bug, and released as ver1.01.

I apologize about problems of the character encoding.
Since many Japanese characters are used in many program codes, problems can not be easily solved.
I will fix the problems of Japanese Character at a later date.
Please wait while few days.

And, someday, I want to create complete English version that is translated.
But the amount of all sentences are so many...

Re: 不具合報告投稿所

#44

by Dixq (管理人) » 1年前

御報告ありがとうございました。
ドレス変更時の自機キャラが表示されるようにした修正版v1.0.1をリリース致しました。

Re: 不具合報告投稿所

#43

by Dixq (管理人) » 1年前

現在出張中で、修正できないのですが、レーザーの自機が表示されないバグをチームが確認しました。
早急に直します。
帰宅したら詳しくお返事します。

Re: 不具合報告投稿所

#42

by ニムロッド » 1年前

Sorry, I didn't see the second part of your message! I'm from the United States (アメリカ).

Re: 不具合報告投稿所

#41

by ニムロッド » 1年前

I was afraid of that, very sorry! I would like to learn Japanese someday, but it's difficult for me right now.

The errors in the images are as shown. The Laser Dress sprite does not appear, and I have to delete SavedBarrageData.dat whenever I run the program.

When I use Japanese locale (whether it's AppLocale or system setting), whenever the program runs, it creates the correct "四聖龍神録2" folder and puts save data there, but it also creates an empty folder with a gibberish name, which is probably just "四聖龍神録2" in the wrong encoding. When I use English locale, I only get the gibberish folder, and save data is put there.

The config program doesn't save. I can edit Config.dat successfully, though I don't know the commands for the GROUP_WINDOW_MODE setting.

These errors all occur in previous 0.9x versions, as well as version 1.00. If any of the errors have to do with Windows 7, I don't know what to do.

If it helps, 四聖龍神録1 currently does not have any of these problems for me. I was also wondering if you would ever work on 四聖龍神録1 again.

Thank you for these games! I've enjoyed them a lot, and I'm looking forward to 四聖龍神録2 Plus.

Re: 不具合報告投稿所

#40

by さくや » 1年前

V1.0.0に上げて一回確認してみましたが、 ニムロッドさんの画像のようなレーザー時のアイシャの画像が出ないです

Re: 不具合報告投稿所

#39

by Dixq (管理人) » 1年前

Hi, ニムロッド.
Can you understand English?
I can write in English for you.

こんにちは。ニムロッドさん。
英語は理解できますか?
英語であれば私はここに書けますがどこの国の方でしょうか?

Re: 不具合報告投稿所

#38

by ニムロッド » 1年前

こんにちは、私は外人で、これを機械翻訳しなければなりませんでした。 あなたが欲しいのであれば、このレポートを無視してください!

Windows 7、8GBメモリ、DirectXなどを再インストールしようとしました。

レーザードレスのスプライトが私のために表示されない(http://i.imgur.com/uxTbwHI.jpg

プログラムを起動するたびにエラーが出る(http://i.imgur.com/BKBvyz9.png)。SavedBarrageData.datファイルを削除すると、ゲームは再び動作しますが、私のスペルカードの履歴は削除されます。 これは0.9xバージョンでも発生します。(私はエラー内容.txtも持っていますが、それはイメージと同じことを言いますが、それが可能であれば添付ファイルをアップロードする方法はわかりません...)

私はこれが呪文カードのエラーと関係があるのかどうかはわかりませんが、ゲームを実行するたびに四聖龍神録2の正しいフォルダの横にΠl??¹-'?? _ ^ 2フォルダが作成されます。 この奇妙なフォルダには独自のSavedDataフォルダがありますが、このフォルダには何も保存されません。

さらに、設定プログラムはまったく保存しません。 GROUP_WINDOW_MODE設定のコマンドは分かりませんが、Config.datを編集して設定を変更することができます...

これらはすべて日本語のロケール(AppLocaleではなくWindowsの設定)を使用するので、英語版のWindowsを使用して私と関係があるかもしれません。 英語のロケールを使用するとΠl??¹-'?? _ ^ 2フォルダーが作成され、ゲームはすべて保存されますが、レーザードレスエラー、スペルカードエラー、Configエラーなどが残ります。英語ロケール+日本語 AppLocaleを通じて、または日本語ロケール+英語からAppLocaleまでの間にエラーが発生します。 別の言語のWindowsロケールまたはAppLocale(?!)、およびさまざまな組み合わせを使用すると、すべて同じ動作になります。

それが助けになるなら、四聖龍神録1には私にこれらの問題はありません。 このゲームのすべては、まだ追加されていないverUP機能以外は素晴らしいものです。そういえば、四聖龍神録1の別バージョンをリリースする予定ですか?

このすべてがWindows 7を実行している私と関係がある場合...私は何をすべきかわかりません。

これらの素晴らしいゲームをありがとう!私はこれが日本語としての資格はないと確信しています。 ごめんなさい!

Re: 不具合報告投稿所

#37

by Dixq (管理人) » 1年前

ノーマルクリアラーさん

御報告ありがとうございます。
v1.00にてご確認頂けると幸いです。

さくやさん

御報告ありがとうございます。
すみませんが、こちらでその状態が発生しません。
透明になっているというのは、画像が表示され無いということですか?

Re: 不具合報告投稿所

#36

by さくや » 1年前

レーザードレスを装備したら、アイシャとレーザーの画像のみ反映されてなくて透明になっています

Re: 不具合報告投稿所

#35

by ノーマルクリアラー » 1年前

> なかったことにすると同時にボムを使うと戻った先のボムが0でもボムを使うことができてしまいます。
再現できないのでおかしいなと思っていたら、別のバグで勘違いしていました。
どうやらボス撃破後のセーブが少し遅いようで回収後にセーブされているようです。
わかりやすいよう動画を録ってみました。
https://www.axfc.net/u/3825662
1 ボム0でクリアしているのになかったことにするとボム1になりアイテムが復活している。
2 上部回収でも同じ現象が発生。ボム1でクリアしているのに2になっている。
3 かけらでも同じ現象が発生。

4 6章中ボス2はやり直してもドロップアイテムが復活しない。
色々試しているときに見つかったのですが、多分不具合ですよね・・・?

>ドロップマニーとはお金のことですか?
某ゲームのせいでマネーをマニーと表記してしまいました。
他のボスは撃破後に落とすお金がなかったことにしても復活しませんが、ここだけ復活しているので不具合なのかな?と思いました。

Re: 不具合報告投稿所

#34

by Dixq (管理人) » 1年前

ノーマルクリアラーさん

> なかったことにすると同時にボムを使うと戻った先のボムが0でもボムを使うことができてしまいます。

すみません、理解が追いつきません。
無かったことにする時はボム1で、戻った先は0で、戻った後にボムを撃つことができるということでしょうか?

> 6章E,Nともに中ボス1のドロップマニーがなかったことにするを選択しても消えていません。

ドロップマニーとはお金のことですか?
お金についてはなかったことにしても継続します。
ボムのことかなと思って見てみましたが正常に動いているように見えます。
なにか他のことでしょうか?

> プラクティス1章Lがプレイできてしまいます。

これはバグですね・・。
プレイ経験がないと遊べないので大丈夫だと思っていましたが1章はプレイ経験が無くてもいいんでした。
修正します。

Re: 不具合報告投稿所

#33

by Dixq (管理人) » 1年前

たろうさん

色んなディスプレイでテストしてみましたが、
環境によっては正常に60FPSで表示されない現象が確認できました。
継続調査します。

Re: 不具合報告投稿所

#32

by Dixq (管理人) » 1年前

にこよんさん

御報告有難うございます。
何故気づかなかったのか・・。
そもそも敵無敵弾幕でホーミングが敵にあたっていること自体がバグでした。

Re: 不具合報告投稿所

#31

by ノーマルクリアラー » 1年前

なかったことにすると同時にボムを使うと戻った先のボムが0でもボムを使うことができてしまいます。
戻った先のボムが1以上ある場合は正常に消費します。

6章E,Nともに中ボス1のドロップマニーがなかったことにするを選択しても消えていません。

プラクティス1章Lがプレイできてしまいます。
クリアしても2章は開放されませんでした、残念。

Re: 不具合報告投稿所

#30

by たろう » 1年前

リフレッシュレートは60ヘルツです。
モニターはちょっと古いやつで、AcerのAL1916Wを使っています。

ただ、ウィンドウモードでも起動できるので、サポートが大変なら無理しないで良いですよ。

Re: 不具合報告投稿所

#29

by にこよん » 1年前

ミッドナイト・レインボーで敵が消えた後も自機のサーチが敵を追い続けてます。

Re: 不具合報告投稿所

#28

by Dixq (管理人) » 1年前

たろうさん

なるほど、FPS計算を2秒置きに行っているので、ちょうどそのタイミングで何かの計算が狂っている可能性があります。
私やベータテスターさんの環境では起こっていないので環境依存するようです。
よろしければたろうさんがお使いのモニタのリフレッシュレートを教えて頂けないでしょうか。

Re: 不具合報告投稿所

#27

by たろう » 1年前

今、プレイしてみましたら、1秒おきでなく、ちょうど2秒おきに0.5秒止まる状態が続きます。
BGMは鳴ったままで、FPSは60のままです。

ウィンドウモードではこの現象は起こりません。
ふと思い、DXライブラリ全般でこの現象が起きるのかと思い、自作のアプリケーションでフルスクリーン処理をしてみましたが、正常に動作しました。
自作のアプリ内のフレームレード制御関数を載せます。何か解決になるとよいのですが…

コード:

class fpsMgr{
	int mStartTime;         //測定開始時刻

public:
	float m_now_fps,m_limit_fps;
	fpsMgr(){
		mStartTime = 0;
		m_now_fps=0;m_limit_fps=0;
	}

	bool Update(){
		mStartTime =  GetNowCount();
		return true;
	}

	void Wait(int FPS){
		m_limit_fps=(float)FPS;
		int tookTime = GetNowCount() - mStartTime;	//かかった時間
		int waitTime = tookTime<1000/FPS? 1000/FPS-tookTime:0;	//待つべき時間
		
		if( waitTime > 0 ){
			Sleep(waitTime);	//待機
			m_now_fps=m_limit_fps;
		}
		else
			m_now_fps=tookTime!=0?m_limit_fps-((float)tookTime-1000/m_limit_fps)/m_limit_fps	:	m_limit_fps;
	}
};

Re: 不具合報告投稿所

#26

by Dixq (管理人) » 1年前

たろうさん

御報告有難うございます。
ウィンドウモードは1280x960ですので、縦900のディスプレイですと縦幅が足りません。
起動後にウィンドウ端をドラッグすることでサイズの調整ができますので、ウィンドウのサイズに調整してみて下さい。

> 60FPS毎に謎の遅延が発生してしまいました。

謎の遅延とはどのような現象でしょうか。
一瞬止まるといった現象でしょうか?
60FPS毎にというのは1秒間に1度と言う意味でしょうか?

Re: 不具合報告投稿所

#25

by たろう » 1年前

画面下が表示されず、ウィンドウモードが正常に表示されません。(640×480は正常に起動しました)
又、フルスクリーンでも起動しましたが、60FPS毎に謎の遅延が発生してしまいました。
windows10 64bit
メモリ8G
ディスプレイ 1440×900

画像

Re: 不具合報告投稿所

#24

by Dixq (管理人) » 1年前

ぽんさん

ご確認頂きありがとうございました。失礼な表示がなされてしまったことお詫び申し上げます。

Re: 不具合報告投稿所

#23

by Dixq (管理人) » 1年前

mimuimuさん

ご確認頂きありがとうございました。
今後とも四聖龍神録2をよろしくお願い致します。

Re: 不具合報告投稿所

#22

by ぽん » 1年前

ちゃんと起動できました!
ありがとうございます。

「弾幕」画面について

#21

by mimuimu » 1年前

先程v0.93をDLしてプレイし、
挙げさせていただいた①と②について両方修正されていることを確認いたしました。
ご対応いただきまして有難うございました。

Re: 不具合報告投稿所

#20

by Dixq (管理人) » 1年前

ぽんさん

情報ありがとうございます。
これはいけませんね・・。
一応アップデート確認したのですが・・。
早急に対応します。

※更新
原因分かりました。
対応した修正バージョンver0.93をリリースしました。
こちらで正常に起動できるはずです。
ご迷惑をおかけして申し訳ございません。

ページトップ